source: spip-zone/_plugins_/elearning/plugin.xml @ 53009

Last change on this file since 53009 was 53009, checked in by eric@…, 8 years ago

Slogan et intervalle supposé compatible 2.0 et 2.1 de SPIP

File size: 1.6 KB
Line 
1<plugin>
2        <nom>E-Learning</nom>
3        <auteur>RastaPopoulos</auteur>
4        <licence>GPL</licence>
5        <version>0.1.0</version>
6        <etat>dev</etat>
7        <slogan>Plate-forme simple de E-Learning</slogan>
8        <description>
9Ce plugin permet d'utiliser SPIP comme une plateforme simple de E-Learning.
10
11Sur le principe, ce plugin est une aggr&#233;ggation de plusieurs plugins, plus des fonctionnalit&#233;s qui lui sont propres.
12_ En plus d'avoir ses cours en ligne, on peut donc faire des tests not&#233;s, voir les connexions et les pages visit&#233;es par les &#233;l&#232;ves, d&#233;finir une progression dans les cours suivant les notes du cours pr&#233;c&#233;dent, etc.
13        </description>
14        <lien>http://www.spip-contrib.net/Plugin-E-learning</lien>
15        <prefix>elearning</prefix>
16        <options>elearning_options.php</options>
17        <fonctions>elearning_fonctions.php</fonctions>
18        <install>base/elearning_installation.php</install>
19       
20        <pipeline>
21                <nom>jeux_caracteristiques</nom>
22                <inclure>elearning_pipelines.php</inclure>
23                <action>jeux_caracteristiques</action>
24        </pipeline>
25       
26        <pipeline>
27                <nom>accesrestreint_liste_zones_autorisees</nom>
28                <action>liste_zones_autorisees</action>
29                <inclure>inc/elearning_zones.php</inclure>
30        </pipeline>
31       
32        <categorie>divers</categorie>
33        <necessite id="spip" version="[2.0.0;2.1.99]" />
34        <!-- Le e-learning dans SPIP nécessite les plugins suivant -->
35        <necessite id='cfg' version="[1.10.5;]" />
36        <necessite id='AccesRestreint' version="[0.3.0.3;]" />
37        <necessite id='bigbrother' version="[0.3;]" />
38        <necessite id='jeux' version="[1.8;]" />
39        <necessite id='Crayons' version="[1.3;]" />
40</plugin>
Note: See TracBrowser for help on using the repository browser.