source: spip-zone/_plugins_/gfc/gfc_options.php @ 70524

Last change on this file since 70524 was 31948, checked in by kent1@…, 11 years ago

Une configuration qui doit être compatible de deux méthodes :

  • par l'intermédiaire de defines et non plus $GLOBALS
  • par l'intermédiaire de CFG

Puisque l'on utilise la bibliothèque originale de opensocial, un fichier doit être ajouté (auth/osapiFCAuth) et un doit surcharger la librairie originale (auth/osapiSecurityToken), la seule manière simple de le faire est de modifier le set_include_path mais je ne suis pas sur que ce soit la meilleure solution

File size: 725 bytes
Line 
1<?php
2
3set_include_path(get_include_path() . PATH_SEPARATOR . getcwd().'/'._DIR_PLUGIN_GFC.'auth');
4
5/**
6 * Definition du repertoire de l'api opensocial
7 * (telechargee automatiquement ou manuellement a l'installation
8 */
9define('_DIR_OSAPI','lib/opensocial-php-client/osapi/');
10
11// USER CONFIG
12
13//consumer id
14define('_GFC_CONSUMER_ID','');
15//consumer key
16define('_GFC_CONSUMER_KEY','');
17//consumer secret
18define('_GFC_CONSUMER_SECRET','');
19//email of members automatically created with this plugin
20define('_GFC_DEFAULT_EMAIL','nobody@noone.com');
21
22//END USER CONFIG
23define('_GFC_COOKIE_NAME','fcauth'._GFC_CONSUMER_ID);
24$GLOBALS['gfc']['cookie_value'] = $_COOKIE[$GLOBALS['gfc']['cookie_name']];
25?>
Note: See TracBrowser for help on using the repository browser.