source: spip-zone/_plugins_/legendes/legendes_administrations.php @ 62592

Last change on this file since 62592 was 62592, checked in by brunobergot@…, 7 years ago

version 1.0.0 : le plugin est compatible spip 2 et spip 3, on passe en stable

File size: 714 bytes
Line 
1<?php
2if (!defined("_ECRIRE_INC_VERSION")) return;
3
4include_spip('inc/meta');
5
6function legendes_upgrade($nom_meta_base_version,$version_cible){
7        $current_version = "0.0";
8        if (    (!isset($GLOBALS['meta'][$nom_meta_base_version]))
9                        || (($current_version = $GLOBALS['meta'][$nom_meta_base_version])!=$version_cible)){
10                include_spip('base/legendes');
11                if ($current_version==0.0){
12                        include_spip('base/create');
13                        include_spip('base/abstract_sql');
14                        creer_base();
15                        ecrire_meta($nom_meta_base_version,$current_version=$version_cible,'non');
16                }
17        }
18}
19
20function legendes_vider_tables($nom_meta_base_version) {
21        sql_drop_table("spip_legendes");
22        effacer_meta($nom_meta_base_version);
23}
24
25?>
Note: See TracBrowser for help on using the repository browser.