source: spip-zone/_plugins_/open_layers/geomap.js_fonctions.php @ 107989

Last change on this file since 107989 was 60141, checked in by webmaster@…, 8 years ago

Dépendance indispensable

Modernisation rendue indispensable par l'arrêt du serveur Osmarender et la suppression de l'API correspondante dans OpenLayers?. Les couches Osmarender et Nasa (Landsat) ne sont plus utilisées. Désormais, le plugin utilise la couche OpenStreetmap? et une couche WMS en option.

Ajout d'icônes et d'une css compatibles avec les dernières versions d'Openlayers.


Enhancement required after Osmarender server stopped definitively. Layers Osmarender and Nasa removed. Plugin now use Openstreemap and optionally any WMS server.
Added some icons and a new css for latest Openlayers versions compliance.

File size: 259 bytes
Line 
1<?php
2// gfd  gfd
3function geomap_cache_map($script){
4        if (preg_match(",http://maps\.google\.com/mapfiles/(.*)\.js,Uims",$script,$regs))
5                $script = str_replace($regs[0],generer_url_public('mapfiles.js','map='.$regs[1].".js",true),$script);
6        return $script;
7}
Note: See TracBrowser for help on using the repository browser.