source: spip-zone/_plugins_/outils_article/trunk/outils_article_administrations.php @ 93421

Last change on this file since 93421 was 93421, checked in by teddy.spip@…, 5 years ago
  • Tentative de mise en conformité du formulaire de configuration ;
  • Ajout de chaine de langue sur le formulaire de configuration pour une meilleure compréhension ;
  • On affiche certaines options que si les plugins référents sont actifs, de même dans les inclure ;
  • Compatibilité SPIP 3.1 ;
  • Up de y pour ces changements.
File size: 506 bytes
Line 
1<?php
2
3function outils_article_upgrade($nom_meta_base_version, $version_cible) {
4        $maj = array();
5        $maj['create'] = array(array('outils_article_corriger_theme'));
6        include_spip('base/upgrade');
7        maj_plugin($nom_meta_base_version, $version_cible, $maj);
8}
9
10function outils_article_corriger_theme() {
11        // éviter de mettre chemin complet du thème
12        $theme = lire_config('outils_article/theme');
13        if ($theme) {
14                $theme = substr(strrchr($theme, '/'), 1);
15                ecrire_config('outils_article/theme', $theme);
16        }
17}
Note: See TracBrowser for help on using the repository browser.