source: spip-zone/_plugins_/svp/svp_options.php @ 48145

Last change on this file since 48145 was 48145, checked in by eric@…, 10 years ago

Renommage pour une meilleure compréhension :

  • svp_afficher_version devient svp_afficher_intervalle
  • version_spip devient compatibilite_spip

Les intervalles par défaut utilisent maintenant la nouvelle syntaxe.

  • Property svn:eol-style set to native
File size: 1.7 KB
Line 
1<?php
2
3// Mise a jour automatique des depots (CRON)
4// - Flag de declenchement
5define('_SVP_CRON_ACTUALISATION_DEPOTS', true);
6// - Periode d'actualisation en nombre d'heures (de 1 a 24)
7define('_SVP_PERIODE_ACTUALISATION_DEPOTS', 6);
8
9// Mise a jour automatique des stats (CRON)
10// - Flag de declenchement
11define('_SVP_CRON_ACTUALISATION_STATS', false);
12// - Periode d'actualisation en nombre de jours
13define('_SVP_PERIODE_ACTUALISATION_STATS', 7);
14// - Adresse de la page fournissant les statistiques par json
15define('_SVP_SOURCE_STATS', 'http://stats.spip.org/spip.php?page=stats.json');
16
17
18// Définition de la boite du logo de depot pour utilisation de iconifier()
19$GLOBALS['logo_libelles']['id_depot'] = _T('svp:titre_boite_logo_depot');
20
21// Type parseur XML a appliquer pour recuperer les infos du plugin
22// - plugin, pour utiliser plugin.xml
23// - paquet, pour paquet.xml
24define('_SVP_DTD_PLUGIN', 'plugin'); 
25define('_SVP_DTD_PAQUET', 'paquet'); 
26
27// Regexp de recherche des balises principales de archives.xml
28define('_SVP_REGEXP_BALISE_DEPOT', '#<depot[^>]*>(.*)</depot>#Uims');
29define('_SVP_REGEXP_BALISE_ARCHIVES', '#<archives[^>]*>(.*)</archives>#Uims');
30define('_SVP_REGEXP_BALISE_ARCHIVE', '#<archive[^>]*>(.*)</archive>#Uims');
31define('_SVP_REGEXP_BALISE_ZIP', '#<zip[^>]*>(.*)</zip>#Uims');
32define('_SVP_REGEXP_BALISE_TRADUCTIONS', '#<traductions[^>]*>(.*)</traductions>#Uims');
33define('_SVP_REGEXP_BALISE_PLUGIN', '#<plugin[^>]*>(.*)</plugin>#Uims');
34define('_SVP_REGEXP_BALISE_PAQUET', '#<paquet[^>]*>(.*)</paquet>#Uims');
35
36// Version SPIP minimale quand un plugin ne le precise pas
37define('_SVP_VERSION_SPIP_MIN', '1.9.0');
38// Intervalles de compatibilite SPIP
39define('_SVP_COMPATIBILITE_SPIP_TOUT', '[1.9.0;[');
40define('_SVP_COMPATIBILITE_SPIP_NA', '];[');
41
42?>
Note: See TracBrowser for help on using the repository browser.