Changeset 100138 in spip-zone


Ignore:
Timestamp:
Oct 25, 2016, 8:50:02 AM (3 years ago)
Author:
kent1@…
Message:

Version 0.6.3 (2016-10-25)

Bien tester l'existence des fichiers avant de tester leur taille (notices PHP).

Ce plugin est pour SPIP > 3.0 et donc nécessite PHP > 5.2 normalement, la compatibilité pour vieux PHP (absence de json_decode() et json_encode()) n'est donc plus nécessaire.

Location:
_plugins_/smush_images/trunk
Files:
2 deleted
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/smush_images/trunk/README.md

    r100100 r100138  
    7373### Versions 0.6.x
    7474
     75#### Version 0.6.3 (2016-10-25)
     76
     77Bien tester l'existence des fichiers avant de tester leur taille (notices PHP).
     78
     79Ce plugin est pour SPIP > 3.0 et donc nécessite PHP > 5.2 normalement, la compatibilité pour vieux PHP (absence de `json_decode()` et `json_encode()`) n'est donc plus nécessaire.
     80
    7581#### Version 0.6.2 (2016-10-23)
    7682
  • _plugins_/smush_images/trunk/inc/smush_image.php

    r100100 r100138  
    1010                        $image = _image_valeurs_trans($im, 'smush');
    1111                        $im = $image['fichier'];
    12                         include_spip('inc/smush_php_compat');
    1312                        if (!file_exists($im)) {
    1413                                return $im;
     
    139138                         * Comparaison des version jpg et png si cela est le cas
    140139                         */
    141                         if ($dest_jpg && $file_size_jpg && filesize($dest) > $file_size_jpg) {
     140                        if ($dest_jpg && $file_size_jpg && file_exists($dest) && filesize($dest) > $file_size_jpg) {
    142141                                spip_unlink($dest);
    143142                                $im = $dest = $dest_jpg;
  • _plugins_/smush_images/trunk/paquet.xml

    r100101 r100138  
    22        prefix="smush"
    33        categorie="performance"
    4         version="0.6.2"
     4        version="0.6.3"
    55        etat="stable"
    66        compatibilite="[3.0.3;3.1.*]"
Note: See TracChangeset for help on using the changeset viewer.