Changeset 100502 in spip-zone


Ignore:
Timestamp:
Nov 14, 2016, 5:55:58 PM (3 years ago)
Author:
cedric@…
Message:

Complement de r100501 : il faut etre administrateur (non restreint) pour envoyer une newsletter

Location:
_plugins_/mailshot/trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/mailshot/trunk/formulaires/newsletter_send.html

    r98720 r100502  
    44        [<p class="reponse_formulaire reponse_formulaire_erreur">(#ENV*{message_erreur})</p>]
    55
     6        [(#ENV{editable}|oui)
    67        <form method="post" action="#ENV{action}">
    78        <div>
     
    4950        </div>
    5051        </form>
     52        ]
    5153
    5254        <INCLURE{fond=prive/objets/liste/mailshots,id=#ENV{_id_newsletter},env,ajax} />
  • _plugins_/mailshot/trunk/formulaires/newsletter_send.php

    r98685 r100502  
    2222                '_mode_test' => $mode_test?$mode_test:'',
    2323                '_id_newsletter' => $id_newsletter,
     24                'editable' => ' ',
    2425        );
     26        include_spip('inc/autoriser');
     27        if (!autoriser('envoyer', 'newsletter', $id_newsletter, null, array('test'=>$mode_test))) {
     28                $valeurs['editable'] = '';
     29        }
    2530
    2631        if (!$mode_test){
  • _plugins_/mailshot/trunk/paquet.xml

    r100326 r100502  
    22        prefix="mailshot"
    33        categorie="communication"
    4         version="1.19.2"
     4        version="1.20.0"
    55        etat="stable"
    66        compatibilite="[3.0.5;3.1.*]"
Note: See TracChangeset for help on using the changeset viewer.