Changeset 103861 in spip-zone


Ignore:
Timestamp:
Apr 10, 2017, 3:32:05 PM (2 years ago)
Author:
cedric@…
Message:

Le plugin pannier2commande est desormais deprecie puisque le plugin panier en version 1.1.0 fait le job lui meme, cf r103860
On note le fait qu'il est deprecie dans son nom, et on modifie la borne sup de necessite sur paniers :

  • si panier est mis a jour mais pas pannier2commande, tout fonctionne sans collision
  • si les 2 sont mis a jour, pannier2commande se desactive tout seul
  • si pannier2commande seul est mis a jour, il continue de fonctionner avec une ancienne version de panier, sans heurt

On passe le plugin en stable, car il n'evoluera plus, donc

Location:
_plugins_/commandes_paniers/trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/commandes_paniers/trunk/lang/paquet-panier2commande_fr.php

    r82215 r103861  
    88        // P
    99        'panier2commande_description' => 'Permet de remplir une commande avec le contenu d\'un panier.',
    10         'panier2commande_nom' => 'Commandes de Paniers',
     10        'panier2commande_nom' => '[Déprécié] Commandes de Paniers',
    1111        'panier2commande_slogan' => 'Remplir une commande',
    1212);
  • _plugins_/commandes_paniers/trunk/paquet.xml

    r99216 r103861  
    22        prefix="panier2commande"
    33        categorie="divers"
    4         version="2.0.4"
    5         etat="test"
     4        version="2.0.5"
     5        etat="stable"
    66        compatibilite="[3.0.0;3.1.*]"
    77        logo="images/panier2commande-32.png"
     
    99>
    1010
    11         <nom>Commandes de Paniers</nom>
     11        <nom>[Deprecie] Commandes de Paniers</nom>
    1212        <auteur lien="http://www.ldd.fr">Les D&#233;veloppements Durables</auteur>
    1313
     
    1515
    1616        <pipeline nom="post_edition" inclure="panier2commande_pipelines.php" />
    17         <pipeline nom="panier2commande_prix" />
     17        <pipeline nom="panier2commande_prix" action="" />
    1818
    1919        <necessite nom="commandes" compatibilite="[1.4.0;]" />
    20         <necessite nom="paniers" compatibilite="[1.0.0;]" />
     20        <necessite nom="paniers" compatibilite="[1.0.0;1.1.0[" />
    2121        <necessite nom="spip_bonux" compatibilite="[3.0.0;]" />
    2222
Note: See TracChangeset for help on using the changeset viewer.