Changeset 106830 in spip-zone


Ignore:
Timestamp:
Oct 13, 2017, 12:34:36 PM (2 years ago)
Author:
marcimat@…
Message:

Comparer avec le numéro de version pour tester si on ne tente pas de downgrader (pas avec 'SPIP ' devant !)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • _outils_/spip_loader/trunk/spip_loader.php

    r106829 r106830  
    7979// v 2.7 : on télécharge maintenant SPIP 3.1
    8080// v 2.5.10 : on télécharge maintenant SPIP 3.2
    81 define('_SPIP_LOADER_VERSION', '2.5.10');
     81// v 2.5.11 : coquille empechant des mises à jour
     82define('_SPIP_LOADER_VERSION', '2.5.11');
    8283#
    8384#######################################################################
     
    872873        // Version proposée à l'installation par défaut
    873874        $versions_spip = lister_versions_spip();
    874         $version_future = 'SPIP ' . $versions_spip[_CHEMIN_FICHIER_ZIP]['version'];
     875        $version_future = $versions_spip[_CHEMIN_FICHIER_ZIP]['version'];
    875876        if ($versions_spip[_CHEMIN_FICHIER_ZIP]['etat'] == 'dev') {
    876877                $version_future .= '-dev';
    877878        }
     879        $version_future_affichee = 'SPIP ' . $version_future;
    878880
    879881        if ($version_installee) {
     
    922924                . '<div class="version-future">'
    923925                . _TT('tradloader:titre_version_future')
    924                 . '<strong>'. $version_future. '</strong>'
     926                . '<strong>'. $version_future_affichee. '</strong>'
    925927                . '</div>'
    926928                . '</div>'
Note: See TracChangeset for help on using the changeset viewer.