Changeset 112978 in spip-zone


Ignore:
Timestamp:
Dec 20, 2018, 9:02:04 AM (4 weeks ago)
Author:
root
Message:

APCu inside (ladnet)

Location:
_plugins_/xray/trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/xray/trunk/paquet.xml

    r112965 r112978  
    22        prefix="xray"
    33        categorie="outil"
    4         version="0.22.0"
     4        version="0.22.1"
    55        etat="test"
    66        compatibilite="[2.1.0;3.2.*]"
  • _plugins_/xray/trunk/plugin.xml

    r112965 r112978  
    99        <licence>GPL</licence>
    1010        <licence>PHP</licence>
    11         <version>0.22.0</version>
     11        <version>0.22.1</version>
    1212        <etat>test</etat>
    1313        <description>
  • _plugins_/xray/trunk/xray_options.php

    r112695 r112978  
    2626global $Memoization;
    2727$cfg = @unserialize($GLOBALS['meta']['memoization']);
    28 if ($Memoization and ($Memoization->methode == 'apc')
    29 and $cfg and ($cfg['methode']=='apc')) {
     28if ($Memoization and
     29        (($Memoization->methode == 'apc') or ($Memoization->methode == 'apcu'))
     30        and $cfg and (($cfg['methode']=='apc') or ($cfg['methode']=='apcu'))) {
    3031        include_once ('xray_apc.php');
    3132        exit;
    3233}
    3334else {
    34         echo "Erreur : le plugin XRay nécessite d'activer le plugin memoization avec APC";
     35        echo "Erreur : le plugin XRay nécessite d'activer le plugin memoization avec APC ou APCu";
    3536        exit;
    3637};
Note: See TracChangeset for help on using the changeset viewer.