Changeset 113317 in spip-zone


Ignore:
Timestamp:
Jan 9, 2019, 2:42:35 PM (2 months ago)
Author:
bystrano@…
Message:

Compatibilité avec la branche de dév de roles_documents

Location:
_plugins_/logos_roles/trunk
Files:
4 added
1 deleted
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/logos_roles/trunk/formulaires/inc-apercu-logo.html

    r107750 r113317  
     1[(#REM)
     2                Depuis la version 1.2.2, le plugin roles_documents embarque sa propre
     3                version de ce squelette. Dans ce cas on inclut un autre fichier qui
     4                surcharge en se basant sur cette nouvelle version.
     5]
     6[(#SET{
     7  roles_documents_actif,
     8  #PLUGIN{roles_documents, version}|version_compare{1.2.2, '>'}
     9})]
     10[(#GET{roles_documents_actif}|oui)
     11  [(#INCLURE{fond=formulaires/inc-apercu-logo-roles-documents, env})]
     12]
     13[(#GET{roles_documents_actif}|non)
     14
     15
    116[(#SET{role, #ENV{quoi}})]
    217
     
    103118        ]
    104119</div>
     120]
  • _plugins_/logos_roles/trunk/logos_roles_fonctions.php

    r113314 r113317  
    341341        return preg_replace(',^spip_|^id_,', '', $type);
    342342}
     343
     344/**
     345 * Gros hack : pour pouvoir fonctionner sans massicot, mais sans non plus
     346 * s'embêter à traiter les deux cas dans les squelettes, on définit ici la
     347 * fonction dont on a besoin, dans le cas où le plugin n'est pas installé.
     348 */
     349if (! test_plugin_actif('massicot')) {
     350        function massicoter_objet($fichier, $objet, $id_objet, $role = null) {
     351
     352                return $fichier;
     353        }
     354}
  • _plugins_/logos_roles/trunk/paquet.xml

    r113311 r113317  
    22        prefix="logos_roles"
    33        categorie="multimedia"
    4         version="0.10.1"
     4        version="0.10.2"
    55        etat="dev"
    66        compatibilite="[3.1.1;3.2.*]"
     
    1616        <licence>GNU/GPL</licence>
    1717
    18         <necessite nom="roles_documents" compatibilite="[1.2.19;[" />
     18        <necessite nom="roles_documents" compatibilite="[1.2.21;[" />
    1919        <necessite nom="saisie_liste" compatibilite="[1.4.14;[" />
    2020
Note: See TracChangeset for help on using the changeset viewer.