Changeset 115189 in spip-zone


Ignore:
Timestamp:
May 2, 2019, 7:51:17 PM (3 weeks ago)
Author:
jluc@…
Message:

restauration : évitons l'erreur php quand sqlite n'est pas bien là fixes #4325

Location:
_core_/plugins/dump
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _core_/plugins/dump/inc/dump.php

    r113294 r115189  
    8383        // chercher si sqlite2 ou 3 est disponible
    8484        include_spip('req/sqlite3');
    85         if (spip_versions_sqlite3()) {
     85        if (function_exists('spip_versions_sqlite3') and spip_versions_sqlite3()) {
    8686                return 'sqlite3';
    8787        }
     88        if (function_exists('spip_versions_sqlite3')) {
     89                spip_log("ERREUR sqlite3 n'est pas correctement installé : "
     90                                        ."extension_loaded('pdo')=".extension_loaded('pdo')
     91                                        ." extension_loaded('pdo_sqlite')=".extension_loaded('pdo_sqlite'),
     92                                _LOG_ERREUR);
     93        }
    8894
    8995        include_spip('req/sqlite2');
    90         if (spip_versions_sqlite2()) {
     96        if (function_exists('spip_versions_sqlite2') and spip_versions_sqlite2()) {
    9197                return 'sqlite2';
    9298        }
  • _core_/plugins/dump/paquet.xml

    r112455 r115189  
    22        prefix="dump"
    33        categorie="maintenance"
    4         version="1.9.2"
     4        version="1.9.3"
    55        etat="stable"
    66        compatibilite="[3.3.0-dev;3.3.*]"
Note: See TracChangeset for help on using the changeset viewer.