Changeset 115506 in spip-zone


Ignore:
Timestamp:
May 28, 2019, 3:25:48 PM (8 months ago)
Author:
real3t@…
Message:

[SoyezCréateurs?] Antichrono (blocs) la première année à afficher n'est pas forcément l'année en cours.

Location:
_squelettes_/soyezcreateurs_net/trunk/plugins/soyezcreateurs
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _squelettes_/soyezcreateurs_net/trunk/plugins/soyezcreateurs/noisettes/plan/inc_antichrono_grid.html

    r115505 r115506  
    1 #SET{currentyear,#DATE|annee}
     1<BOUCLE_FirstYear(DATA)
     2                {source table,#ENV{listeliens}}
     3                {!par date}
     4                {fusion year}
     5                {0,1}
     6        >#SET{firstyear,#YEAR}</BOUCLE_FirstYear>
    27[(#SET{logoyear,[(#CHEMIN{images/calendar-year.jpg}|image_focus{308,#CONFIG{soyezcreateurs/hauteur_quoi2neuf,340}})]})]
    38[(#SET{logomonth,[(#CHEMIN{images/calendar-month.jpg}|image_focus{308,#CONFIG{soyezcreateurs/hauteur_quoi2neuf,340}})]})]
     
    1621                {fusion year}
    1722        >
    18                 <li>[(#ENV{year,#GET{currentyear}}|=={#YEAR}|?{<strong>,<a href="[(#SELF|parametre_url{'year',[(#YEAR|!={#GET{currentyear}}|?{#YEAR,''})]})]" class="ajax">})]#YEAR[(#ENV{year}|=={#YEAR}|?{</strong>,</a>})]</li>
     23                <li>[(#ENV{year,#GET{firstyear}}|=={#YEAR}|?{<strong>,<a href="[(#SELF|parametre_url{'year',[(#YEAR|!={#GET{firstyear}}|?{#YEAR,''})]})]" class="ajax">})]#YEAR[(#ENV{year}|=={#YEAR}|?{</strong>,</a>})]</li>
    1924        </BOUCLE_Sommaire>
    2025        </ul>
     
    2833        <BOUCLE_AnneeObjet(DATA)
    2934                {source table,#ENV{listeliens}}
    30                 {year=#ENV{year,#GET{currentyear}}}
     35                {year=#ENV{year,#GET{firstyear}}}
    3136                {!par date}
    3237                {fusion year}
  • _squelettes_/soyezcreateurs_net/trunk/plugins/soyezcreateurs/paquet.xml

    r115504 r115506  
    22        prefix="soyezcreateurs"
    33        categorie="squelette"
    4         version="5.0.53"
     4        version="5.0.54"
    55        etat="stable"
    66        compatibilite="[3.1.8;3.2.*]"
Note: See TracChangeset for help on using the changeset viewer.