Changeset 125158 in spip-zone


Ignore:
Timestamp:
Jun 12, 2020, 12:57:48 PM (2 months ago)
Author:
Maïeul Rouquette
Message:

Plutot que d'imposer brutalement une version de PHP, dire que si la version de PHP n'est pas présente, on ne gère pas le cas des champs contenant des valeurs serialisées

Location:
_plugins_/correction_liens_internes/trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/correction_liens_internes/trunk

    • Property subgit:lock:74bb7383b7a0bc613eb3f6a754e218cc5ae58169 deleted
    • Property subgit:lock:907363af4e3c883829d3c304570eb191ddac4462 set to 2020-06-12T14:57:58.682
  • _plugins_/correction_liens_internes/trunk/correction_liens_internes_pipelines.php

    r125157 r125158  
    9595        $serialize_php = false;
    9696        if ($tmp = @unserialize($texte)) {
     97                if (!defined('JSON_UNESCAPED_SLASHES')) {//On traite pas ce cas pour les version de php < 5.4
     98                        return $texte;
     99                }
    97100                $texte = json_encode($tmp, JSON_UNESCAPED_SLASHES);
    98101                $serialize_php =  true;
  • _plugins_/correction_liens_internes/trunk/paquet.xml

    r125153 r125158  
    22        prefix="correction_liens_internes"
    33        categorie="edition"
    4         version="1.5.3"
     4        version="1.5.4"
    55        etat="stable"
    66        compatibilite="[3.0.0;3.2.*]"
     
    2020        <pipeline nom="pre_edition" inclure="correction_liens_internes_pipelines.php" />
    2121
    22         <necessite nom="PHP" compatibilite="[5.4.0;[" />
    2322        <utilise nom="multidomaines" compatibilite="[2.0.0;]" />
    2423</paquet>
Note: See TracChangeset for help on using the changeset viewer.