Changeset 26896 in spip-zone


Ignore:
Timestamp:
Feb 24, 2009, 9:50:36 AM (11 years ago)
Author:
real3t@…
Message:

Finalement, SPIP 2.0.4 n'a pas jQuery 1.3.2.

Mais ce n'est que pour SPIP < 2.0.0 que les [@attr=] sont nécessaires, SPIP 2 a déjà une version de jquery (1.2.x) qui marche sans le @

Du coup, ça rend le CS compatible avec jquery 1.3.2, tout comme SPIP 2.0.4

Location:
_plugins_/_stable_/couteau_suisse
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/_stable_/couteau_suisse/config_outils.php

    r26660 r26896  
    88#-----------------------------------------------------#
    99if (!defined("_ECRIRE_INC_VERSION")) return;
    10 // selecteur "[@" exclu par jQuery 1.3.1
    11 @define('_SEL_JQUERY', defined('_SPIP20100')?'':'@');
     10// selecteur "[@" inutile depuis jQuery 1.2.x (intégré depuis SPIP 2)
     11@define('_SEL_JQUERY', defined('_SPIP19300')?'':'@');
    1212
    1313// Noter :
  • _plugins_/_stable_/couteau_suisse/cout_options.php

    r26874 r26896  
    1919if (version_compare($GLOBALS['spip_version_code'],'1.9300','>=')) {     
    2020        @define('_SPIP19300', 1); @define('_SPIP19200', 1);
    21         if (version_compare(substr($GLOBALS['spip_version_branche'],0,5),'2.0.4','>=')) @define('_SPIP20100', 1);
     21        if (version_compare(substr($GLOBALS['spip_version_branche'],0,5),'2.1.0','>=')) @define('_SPIP20100', 1);
    2222}
    2323elseif (version_compare($GLOBALS['spip_version_code'],'1.9200','>=')) @define('_SPIP19200', 1);
Note: See TracChangeset for help on using the changeset viewer.