Changeset 43269 in spip-zone


Ignore:
Timestamp:
Dec 31, 2010, 3:11:34 PM (10 years ago)
Author:
paladin@…
Message:

ne pas bloquer si apache_get_version() non disponible

Location:
_plugins_/get_info_spip
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/get_info_spip/exec/get_infos_spip.php

    r41609 r43269  
    120120                $infos = array(
    121121                          'OS' => php_uname() . ' - ' . (PHP_INT_SIZE * 8).' bits'
    122                         , 'Apache version' => apache_get_version()
    123                         , 'Apache modules' => apache_get_modules()
     122                        , 'Apache version' => (function_exists('apache_get_version') ? apache_get_version() : null)
     123                        , 'Apache modules' => (function_exists('apache_get_modules') ? apache_get_modules() : null)
    124124                        , 'PHP version' => phpversion()
    125125                        , 'SQL version' => gins_sqlversion()
  • _plugins_/get_info_spip/plugin.xml

    r42328 r43269  
    2525        <lien>http://www.quesaco.org/Informations-SPIP-Get-Info-GInS</lien>
    2626       
    27         <version>1.2.2</version>
     27        <version>1.2.3</version>
    2828        <etat>stable</etat>
    2929       
Note: See TracChangeset for help on using the changeset viewer.