Changeset 53821 in spip-zone


Ignore:
Timestamp:
Oct 28, 2011, 6:49:49 PM (9 years ago)
Author:
lesage.sylvain@…
Message:

il manquait yandex dans la liste des API avec clé obligatoire

Location:
_plugins_/gis/branches
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/gis/branches/v2/formulaires/config_gis_fonctions.php

    r52788 r53821  
    99/**
    1010 * Fonction de verification du formulaire de configuration CFG
    11  * - On vérifie si dans les cas de cloudmade ou de google (v2), une clé a
    12  * été fournie
     11 * - On vérifie si dans les cas de cloudmade, de google (v2) ou de
     12 *   yandex, une clé a été fournie
    1313 */
    1414function cfg_config_gis_verifier(&$cfg){
    15         if(in_array($cfg->val['api'],array('cloudmade','google'))){
     15        if(in_array($cfg->val['api'],array('cloudmade','google','yandex'))){
    1616                $obligatoire = "api_key_".$cfg->val['api'];
    1717                if(!$cfg->val[$obligatoire]){
  • _plugins_/gis/branches/v2_cluster/formulaires/config_gis_fonctions.php

    r52788 r53821  
    99/**
    1010 * Fonction de verification du formulaire de configuration CFG
    11  * - On vérifie si dans les cas de cloudmade ou de google (v2), une clé a
    12  * été fournie
     11 * - On vérifie si dans les cas de cloudmade, de google (v2) ou de
     12 *   yandex, une clé a été fournie
    1313 */
    1414function cfg_config_gis_verifier(&$cfg){
    15         if(in_array($cfg->val['api'],array('cloudmade','google'))){
     15        if(in_array($cfg->val['api'],array('cloudmade','google','yandex'))){
    1616                $obligatoire = "api_key_".$cfg->val['api'];
    1717                if(!$cfg->val[$obligatoire]){
Note: See TracChangeset for help on using the changeset viewer.