Changeset 61692 in spip-zone


Ignore:
Timestamp:
May 25, 2012, 10:18:24 PM (7 years ago)
Author:
fil@…
Message:

activer ce plugin sous SPIP 3.1-trunk ; pour l'instant il ne sait pas faire grand chose car il n'a ni modeles ni oembed

Location:
_plugins_/ressource
Files:
3 added
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/ressource/inc/ressource.php

    r61366 r61692  
    163163
    164164        include_spip('fonctionsale');
    165         $u = sale(spip_file_get_contents($meta['local']));
    166 
    167         $meta['fullextract'] = $u;
    168         $meta['extract'] = propre(couper($u, 500));
     165        if (function_exists('sale')) {
     166                $u = sale(spip_file_get_contents($meta['local']));
     167
     168                $meta['fullextract'] = $u;
     169                $meta['extract'] = propre(couper($u, 500));
     170        }
    169171}
    170172
     
    395397                        $conv = converthtml($meta['local'], $err);
    396398                        include_spip('fonctionsale');
    397                         $conv = sale($conv);
     399                        if (function_exists('sale')) {
     400                                $conv = sale($conv);
     401                        }
    398402                        break;
    399403                default:
  • _plugins_/ressource/plugin.xml

    r61366 r61692  
    2525        <chemin dir='' />
    2626        <categorie>edition</categorie>
    27         <necessite id="SPIP" version="[2.1.14;3.0.99]" />
     27        <necessite id="SPIP" version="[2.1.14;3.1.99]" />
    2828        <necessite id="tw" version="[0.8.3;1.0.0]" />
    2929        <!-- traduire gestionnaire="salvatore" module="crayons" reference="fr" / -->
Note: See TracChangeset for help on using the changeset viewer.