Changeset 61742 in spip-zone


Ignore:
Timestamp:
May 27, 2012, 1:32:05 PM (7 years ago)
Author:
denisb@…
Message:

svp : suivre http://core.spip.org/projects/spip/repository/revisions/19476 ( suite de http://zone.spip.org/trac/spip-zone/changeset/61726 )

Location:
_core_/plugins/svp
Files:
4 edited

Legend:

Unmodified
Added
Removed
  • _core_/plugins/svp/formulaires/inc-admin_plugin.html

    r60409 r61742  
    44        <ul class="liste-items">
    55<BOUCLE_plugins(PAQUETS plugins){tout}{par multi nom, paquets.prefixe}{!par constante, actif}{id_depot=0}{actif ?}{constante ?IN #ENV{constante}}>
    6                 #SET{incompatible, #COMPATIBILITE_SPIP|plugin_version_compatible{#GET{vspip}}|non}
     6                #SET{incompatible, #COMPATIBILITE_SPIP|plugin_version_compatible{#GET{vspip}, spip}|non}
    77                #SET{verrou,#CONSTANTE|=={_DIR_PLUGINS_DIST}|oui}
    88                <li class="item[ (#ACTIF|=={oui}|?{actif,inactif})][(#OBSOLETE|=={oui}|ou{#ATTENTE|=={oui}}|ou{#GET{incompatible}}|oui) disabled][(#GET{incompatible}|oui) incompatible][(#GET{verrou}|oui) verrou][(#MAJ_VERSION|oui) up]"[ id="(#PREFIXE|strtolower)-#COMPTEUR_BOUCLE"][ data-id_paquet="(#ID_PAQUET)"]>
  • _core_/plugins/svp/inc/svp_decider.php

    r61726 r61742  
    225225                if ($locaux and count($locaux['p'][$prefixe]) > 0) {
    226226                        foreach ($locaux['p'][$prefixe] as $new) {
    227                                 if (plugin_version_compatible($version, $new['v'],'plug')
     227                                if (plugin_version_compatible($version, $new['v'])
    228228                                and svp_verifier_compatibilite_spip($new['compatibilite_spip']) ){
    229229                                        return $new;
     
    239239                if ($distants and count($distants['p'][$prefixe]) > 0) {
    240240                        foreach ($distants['p'][$prefixe] as $new) {
    241                                 if (plugin_version_compatible($version, $new['v'],'plug')
     241                                if (plugin_version_compatible($version, $new['v'])
    242242                                and svp_verifier_compatibilite_spip($new['compatibilite_spip']) ){
    243243                                        return $new;
     
    589589                                // le core procure le paquet que l'on demande !
    590590                                elseif ((array_key_exists($p, $this->procure))
    591                                   and (plugin_version_compatible($v, $this->procure[$p]))) {
     591                                  and (plugin_version_compatible($v, $this->procure[$p], 'spip'))) {
    592592                                        // rien a faire...
    593593                                        $this->log("-- est procure par le core ($p)");
     
    603603                                        if ($ninfo = $this->sera_actif($p)
    604604                                        and !$err = $this->en_erreur($ninfo['i'])
    605                                         and plugin_version_compatible($v, $ninfo['v'],'plug')) {
     605                                        and plugin_version_compatible($v, $ninfo['v'])) {
    606606                                                // il est deja actif ou a activer, et tout est ok
    607607                                                $this->log('-- dep OK pour '.$info['p'].' : '.$p);
  • _core_/plugins/svp/inc/svp_phraser.php

    r57604 r61742  
    174174                                // Si on est pas en mode runtime on prend tout !
    175175                                if (!_SVP_MODE_RUNTIME
    176                                 OR (_SVP_MODE_RUNTIME AND plugin_version_compatible($xml['compatibilite'], $version_spip))) {
     176                                OR (_SVP_MODE_RUNTIME AND plugin_version_compatible($xml['compatibilite'], $version_spip, 'spip'))) {
    177177                                        $paquets[$zip['file']] = $zip;
    178178                                        $paquets[$zip['file']]['traductions'] = $traductions;
  • _core_/plugins/svp/inc/svp_rechercher.php

    r60089 r61742  
    178178        if (!$version_spip)
    179179                $version_spip = $GLOBALS['spip_version_branche'].".".$GLOBALS['spip_version_code'];
    180         return plugin_version_compatible($intervalle, $version_spip);
     180        return plugin_version_compatible($intervalle, $version_spip,'spip');
    181181}
    182182
Note: See TracChangeset for help on using the changeset viewer.