Changeset 80669 in spip-zone for _plugins_/acces_restreint


Ignore:
Timestamp:
Feb 13, 2014, 11:25:04 AM (7 years ago)
Author:
cedric@…
Message:

reparer l'upgrade depuis des vieilles versions dont le prefixe contenait des majuscules (mais peut etre ce probleme devrait etre réglé de manière générique dans l'upgrade des plugins par une requete SQL au lieu d'un acces à la globale) ?

Location:
_plugins_/acces_restreint/trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/acces_restreint/trunk/accesrestreint_administrations.php

    r67731 r80669  
    1616 */
    1717function accesrestreint_upgrade($nom_meta_base_version,$version_cible){
     18
     19        // le prefixe est passe des majuscules aux minuscules :
     20        if (isset($GLOBALS['meta']['AccesRestreint_base_version']) AND !isset($GLOBALS['meta'][$nom_meta_base_version]))
     21                $GLOBALS['meta'][$nom_meta_base_version] = $GLOBALS['meta']['AccesRestreint_base_version'];
    1822
    1923        $maj = array();
  • _plugins_/acces_restreint/trunk/paquet.xml

    r74479 r80669  
    22        prefix="accesrestreint"
    33        categorie="auteur"
    4         version="3.8.8"
     4        version="3.8.9"
    55        etat="stable"
    66        compatibilite="[3.0.0;3.0.*]"
Note: See TracChangeset for help on using the changeset viewer.