Changeset 81231 in spip-zone


Ignore:
Timestamp:
Mar 6, 2014, 10:17:54 AM (5 years ago)
Author:
fil@…
Message:

compatibilite du demarrage du crayon avec jQuery 1.9 (a tester)

Location:
_plugins_/crayons
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/crayons/js/crayons.js

    r75756 r81231  
    544544        // demarrer les crayons
    545545        if ((typeof crayons_init_dynamique == 'undefined') || (crayons_init_dynamique==false)) {
     546
     547                // compat jQuery 1.9
     548                if (typeof $.fn.live == 'undefined') {
     549                        $.fn.live = function( types, data, fn ) {
     550                                $( this.context ).on( types, this.selector, data, fn );
     551                                return this;
     552                        };
     553                }
    546554                $('.crayon:not(.crayon-init)')
    547555                .live('mouseover touchstart', function(e) {
  • _plugins_/crayons/paquet.xml

    r80169 r81231  
    22        prefix="crayons"
    33        categorie="edition"
    4         version="1.17.0"
     4        version="1.18.0"
    55        etat="stable"
    66        compatibilite="[1.9.0;3.*.*]"
  • _plugins_/crayons/plugin.xml

    r80169 r81231  
    1717        </licence>
    1818        <version>
    19         1.17.0
     19        1.18.0
    2020        </version>
    2121        <etat>
Note: See TracChangeset for help on using the changeset viewer.