Changeset 89965 in spip-zone


Ignore:
Timestamp:
Jun 6, 2015, 7:48:50 PM (6 years ago)
Author:
real3t@…
Message:

Voici qui permet de tester facilement les plugins pas encore compatibles avec SPIP 3.1, y compris le téléchargement et l'activation des <necessite>.
Certes, c'est aussi une configuration possible via ecrire/?exec=configurer_svp
Mais un dev qui est capable de mettre dans son mes_options.php :
define('_DEV_PLUGINS','3.1.*');
s'attend à ce que ça puisse lui permettre d'utiliser SVP sans contrainte.
Voilà qui est désormais le cas.

Location:
_core_/plugins/svp
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _core_/plugins/svp/inc/svp_phraser.php

    r82359 r89965  
    2222 * Runtime est le mode par defaut
    2323 * @var bool */
    24         define('_SVP_MODE_RUNTIME', (lire_config('svp/mode_runtime', 'oui') == 'oui' ? true : false));
     24        if (defined('_DEV_PLUGINS')) {
     25                define('_SVP_MODE_RUNTIME', false);
     26        } else {
     27                define('_SVP_MODE_RUNTIME', (lire_config('svp/mode_runtime', 'oui') == 'oui' ? true : false));
     28        }
    2529}
    2630
  • _core_/plugins/svp/paquet.xml

    r89932 r89965  
    22        prefix="svp"
    33        categorie="maintenance"
    4         version="0.86.7"
     4        version="0.86.8"
    55        etat="stable"
    66        compatibilite="[3.0.0;3.1.*]"
Note: See TracChangeset for help on using the changeset viewer.