Changeset 91511 in spip-zone


Ignore:
Timestamp:
Aug 27, 2015, 6:54:05 PM (6 years ago)
Author:
marcimat@…
Message:
  • Ne pas pouvoir indiquer le même auteur en source et destination (xdjuj)
  • Compat structure formulaire 3.0
  • Pas besoin du plugin Vérifier.
Location:
_plugins_/rao
Files:
4 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/rao/formulaires/reassocier_auteur_objets.html

    r91510 r91511  
    2828                ]
    2929
    30                 <div class='editer-groupe'>
     30                <[(#VAL{ul}|saisie_balise_structure_formulaire)] class='editer-groupe'>
    3131                        [(#SAISIE{auteurs, auteur_source,
    3232                                class=chosen,
     
    4242                                label=<:rao:label_objets:>,
    4343                                explication=<:rao:label_objets_explication:>})]
    44                 </div>
     44                </[(#VAL{ul}|saisie_balise_structure_formulaire)]>
    4545
    4646                <div class='boutons'>
  • _plugins_/rao/formulaires/reassocier_auteur_objets.php

    r91510 r91511  
    3535        if (!$objets) {
    3636                $erreurs['objets'] = _T('info_obligatoire');
     37        }
     38        if ($source and $source == $destination) {
     39                $erreurs['auteur_destination'] = _T('rao:erreur_auteurs_identiques');
    3740        }
    3841
  • _plugins_/rao/lang/rao_fr.php

    r91510 r91511  
    88        // B
    99        'bouton_confirmer' => 'Confirmer',
     10
     11        // E
     12        'erreur_auteurs_identiques' => 'Veuillez indiquer des auteurs différents !',
    1013
    1114        // L
  • _plugins_/rao/paquet.xml

    r91510 r91511  
    22        prefix="rao"
    33        categorie="auteur"
    4         version="1.0.0"
     4        version="1.0.1"
    55        etat="test"
    66        compatibilite="[3.0.0;3.1.*]"
     
    1919
    2020        <necessite nom="saisies" compatibilite="[1.24.0;]" />
    21         <necessite nom="verifier" compatibilite="[0.1.10;]" />
    2221        <necessite nom="chosen" compatibilite="[1.0.0;]" />
    2322
Note: See TracChangeset for help on using the changeset viewer.