Changeset 93350 in spip-zone


Ignore:
Timestamp:
Dec 2, 2015, 6:03:36 PM (5 years ago)
Author:
marcimat@…
Message:

Un require vide doit s'écrire {} et non []. On force le json en objet. À voir si ça fonctionne à chaque fois :) + Indiquer qu'on necessite php 5.4.

Location:
_plugins_/composer/trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/composer/trunk/inc/composer_json.php

    r93343 r93350  
    106106        **/
    107107        public function get_json() {
    108                 return json_encode($this->data, JSON_PRETTY_PRINT | JSON_UNESCAPED_SLASHES | JSON_UNESCAPED_UNICODE );
     108                return json_encode($this->data, JSON_PRETTY_PRINT | JSON_UNESCAPED_SLASHES | JSON_UNESCAPED_UNICODE | JSON_FORCE_OBJECT );
    109109        }
    110110}
  • _plugins_/composer/trunk/paquet.xml

    r93345 r93350  
    22        prefix="composer"
    33        categorie="outil"
    4         version="1.0.1"
     4        version="1.0.2"
    55        etat="experimental"
    66        compatibilite="[3.1.0-rc;3.1.*]"
     
    1919        <pipeline nom="preparer_composer_json" action="" />
    2020
     21        <!-- necessite nom="php" compatibilite="[5.4;]" / -->
     22
    2123        <menu nom="composer" titre="composer:composer_titre" parent="menu_administration" icone="images/composer-16.png" />
    2224
Note: See TracChangeset for help on using the changeset viewer.