Changeset 95697 in spip-zone


Ignore:
Timestamp:
Mar 2, 2016, 2:11:24 PM (3 years ago)
Author:
brunobergot@…
Message:

version 1.6.1 : ne pas utiliser curl si sa version est inférieure à 7.10.8

L'option CURLOPT_IPRESOLVE n'est pas disponible sur les vieilles versions de curl cf http://contrib.spip.net/oEmbed-4407#forum486368

Location:
_plugins_/oembed
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/oembed/inc/oembed_recuperer_url.php

    r93685 r95697  
    2121        // on recupere le contenu de la page
    2222        // si possible via curl en IPv4 car youtube bug en IPv6
    23         if (function_exists('curl_init')){
     23        // uniquement si curl est dispo en version 7.10.8 mini
     24        if (function_exists('curl_init') and $curl_version = curl_version() and version_compare($curl_version['version'], '7.10.8', '>=')) {
    2425                spip_log('Requete oembed (curl) pour '.$url.' : '.$oembed_url,'oembed.'._LOG_DEBUG);
    2526                $c = curl_init();
  • _plugins_/oembed/paquet.xml

    r94486 r95697  
    22        prefix="oembed"
    33        categorie="multimedia"
    4         version="1.6.0"
     4        version="1.6.1"
    55        etat="stable"
    66        compatibilite="[3.0.0;3.1.*]"
Note: See TracChangeset for help on using the changeset viewer.