Changeset 96918 in spip-zone


Ignore:
Timestamp:
May 1, 2016, 2:08:33 PM (5 years ago)
Author:
eric@…
Message:

Ajout de la version du plugin SVP API HTTP dans le contenu de chaque réponse.

Location:
_plugins_/svp_api/trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/svp_api/trunk/inc/svpapi_reponse.php

    r96912 r96918  
    7878 *      - `erreur`  : sous-tableau des éléments descriptifs d'une erreur (status 200 par défaut)
    7979 *      - `schema`  : la version du schéma du plugin SVP hébergé par le serveur
     80 *      - `version` : la version du plugin SVP API HTTP fonctionnant sur le serveur
    8081 *      - `donnees` : le tableau des objets demandés fonction de la requête (vide)
    8182 */
    8283function reponse_initialiser_contenu($requete) {
    8384
    84         // Récupération du schéma de données de SVP
     85        // Récupération du schéma de données de SVP et de la version du plugin SVP API HTTP
    8586        include_spip('inc/config');
    8687        $schema = lire_config('svp_base_version');
     88        include_spip('inc/filtres');
     89        $informer = charger_filtre('info_plugin');
     90        $version = $informer('svpapi', 'version', true);
    8791
    8892        // Stockage des éléments de la requête
     
    112116                'erreur'  => $erreur,
    113117                'schema'  => $schema,
     118                'version' => $version,
    114119                'donnees' => array()
    115120        );
  • _plugins_/svp_api/trunk/paquet.xml

    r96912 r96918  
    22        prefix="svpapi"
    33        categorie="outil"
    4         version="0.4.1"
     4        version="0.4.2"
    55        etat="test"
    66        compatibilite="[3.0.0;3.1.*]"
Note: See TracChangeset for help on using the changeset viewer.