Changeset 99175 in spip-zone


Ignore:
Timestamp:
Aug 16, 2016, 8:23:58 AM (3 years ago)
Author:
p@…
Message:

Compatible 3.1

La fonction table_objet_sql existe en SPIP 2.1
On l'utilise plutôt qu'une comparaison de version, cela permet la
compatibilité SPIP 3.1.

Testé sur 3.1.0 et 2.1.28

Location:
_plugins_/forum_sectorise
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • _plugins_/forum_sectorise/forumsectorise_pipelines.php

    r58917 r99175  
    55        include_spip('inc/plugin');
    66        include_spip('inc/config');
    7         if(spip_version_compare($GLOBALS['spip_version_branche'],"2.1.99","<")) {
    8                 $table = 'spip_articles' ;
    9         } else {
    10                 $table = 'spip_article' ;
    11         }
    127
    138        $conf_forumsectorise = lire_config('forumsectorise');
    14         if (($flux['args']['table'] == $table) &&
     9
     10        if (($flux['args']['table'] == table_objet_sql('article')) &&
    1511                 in_array($flux['data']['id_secteur'], $conf_forumsectorise['ident_secteur'])) {
    1612                $flux['data']['accepter_forum'] = $conf_forumsectorise['type'];
  • _plugins_/forum_sectorise/paquet.xml

    r84587 r99175  
    44        version="0.6.0"
    55        etat="stable"
    6         compatibilite="[2.1.0;3.0.*]"
     6        compatibilite="[2.1.0;3.1.*]"
    77        logo="prive/themes/spip/images/forumsectorise-32.png"
    88        schema="0.3"
  • _plugins_/forum_sectorise/plugin.xml

    r84587 r99175  
    4242                <url>configurer_forumsectorise</url>
    4343        </bouton>
    44         <necessite id="SPIP" version="[2.1.0;3.0.99]" />
     44        <necessite id="SPIP" version="[2.1.0;3.1.99]" />
    4545        <necessite id="saisies" version="[1.9.0;]" />
    4646        <necessite id="spip_bonux" version="[1.8;]" />
Note: See TracChangeset for help on using the changeset viewer.