Opened 13 years ago

Last modified 12 years ago

#35 new defect

Problème plugin coloration_code

Reported by: comrade Owned by: mortimerpa
Priority: élevée Component: plugins
Severity: normale Keywords:
Cc:

Description

Comportement étrange sur un article en utilisant coloration_code : http://zine.spip.org/spip.php?article17 Lorsque je mets des classes <code class="html4strict>, j'obtiens des messages, tant dans l'espace public que privé :

Warning: fopen(IMG/cache-code/08cb58abeedd06de6b1c0b9b7e290d67.txt) [function.fopen]: failed to open stream: Permission denied in /home/spipzine/public_html/plugins/_typo_/coloration_code/coloration_code.php on line 64

Warning: fwrite(): supplied argument is not a valid stream resource in /home/spipzine/public_html/plugins/_typo_/coloration_code/coloration_code.php on line 65

Warning: fclose(): supplied argument is not a valid stream resource in /home/spipzine/public_html/plugins/_typo_/coloration_code/coloration_code.php on line 66

À la suite de ces lignes (reproduites plusieurs fois, il y a plusieurs <code…>), l'article est bien là, coloré, mais avec un problème d'encodage.

Pourtant, un autre article qui utilise le plugin sur le même site (svn [6679]) passe sans problème : http://zine.spip.org/spip.php?article8. De plus, sur mon site de test en b3 [6600], l'article en question passe très bien chez moi (Mac, Safari et Firefox), mais pas chez Cédric (FF Windows), qui obtient le même comportement que sur spipzine.

Voilà pour le mystère du jour !

Change History (0)

Note: See TracTickets for help on using tickets.